Attachments in tickets

Hi there,

This should be a quick one.

We have some rules that create tickets manually rather than using the workflow.
We want to be able to add the attachments to the ticket but not sure what the fields need to be for the action.
It requires 3 pieces of information:
Parent type
Parent ID

After doing some editing on the rule, the first and 3rd fields became dropdown options (initially I had no idea what they should be) so they are easy, but I am not sure how to match the Parent ID.

I tried to use the id of the new ticket I created but that doesn’t seem to work.
The error refers to a UDF field being incorrect rather than the Parent ID so Iam not sure what needs to go in here.

Exception: “Autotask field [UserDefinedFields] on entity [AttachmentInfo] is invalid.”

This one is indeed easy since it’s caused by a bug in our UI.

When you first created that action, it was a different Autotask action. You then changed it to be a “Create Attachments” action. That left some of the old action’s settings (the UDFs) in the new action.

If you create a new action step for the attachment, and delete the action there, it will work perfectly. Basically, the settings for the action are corrupted and this one action needs to be re-created.

Thanks Travis.

That looks like it fixed my issue

Hi travis,

That fixed my issue a few weeks ago but I have come across another issue which is similar but Iam not sure if it is the same.

I created a new rule and ran into the same issue with the attachments because I had cloned a step.

I then deleted my cloned step and added a new step to save the attachments.
However, I can’t unlock the fields to let me select the Parent Type or Publish fields. It just stays permanently greyed out.
(Initially when I had cloned a step and then changed it to Save Attachments I was able to unlock the fields)


Hey @nmcmahon ,

This is a bug that will be resolved in our next release. To get around it, just type a number and then delete it in the field, and the lock/unlock button will be come available.

thanks Travis,

I had been entering text with no success but using numbers works a treat.